Spyro: Shadow Legacy


What game do you want next?
View Results
darkSpyro - Spyro and Skylanders Forum > Spyro: Shadow Legacy > Game Breaking Glitch? (Need Help)
Page 1 of 1
Game Breaking Glitch? (Need Help) [CLOSED]
AirSuperiority Green Sparx Gems: 252
#1 Posted: 21:04:43 24/11/2013 | Topic Creator
So basically, when I arrived in Avalar I had trouble finding the realm portal in Hunters area. So I skipped ahead to the volcanic area. I rescued the people there as my 1st objective completed in Avalar. Then I was able to reach the map with the professor after taking an elevator. He asked me to defeat the shadow minion. So I go inside and defeat the Fire Minion (At the time I thought it was strange to have 2 of the 3 boss battles so close to one another because I had just recently defeated the Ice Minion) . The professor then was freed and gave me the option to travel to the next chapter of the game. I refused and decided to do a bit more exploring in Avalar.

Long story short. When I was at the sorcerer doorstep, I realized I couldn't open the gate. I open the map and I see that the objective to defeat the fire minion is still on the map. A little while later I complete all side quests/ objectives and It says I still need 1 more relic to open the door to engage the final boss. Once again I look on the map, the only 2 objectives that are left are defeat the shadow minion and the sorcerer.

When I walk up to the door for the fire minion a 2nd time, the professor is not there because I rescued him VERY early on and I cannot open the door to battle the fire minion again. I tried opening the door in both shadow and normal realm.

I don't know what to do at this point. Any ideas?
theuone Platinum Sparx Gems: 5641
#2 Posted: 20:55:05 25/11/2013
hmm i dont know how to help you but it sounds like you encountered what i call a progress-stoping glitch, which basicly is a glitch that prohibits further progress. i have encountered such glitches before in RAC UYA, and Jak 2. Anyway the only thing you can do as far as i know is to start over. yeah thats all you can do, it sucks.
On board Spyro Reignited hype, Choo choo!
Thanks to BlackWing116 for the Chimera drawing
Metaphorical phantom here, Blame everything lol.
somePerson Platinum Sparx Gems: 6441
#3 Posted: 04:26:21 25/12/2013
Return the game.
rick and morty season 3, episode 3, 00:30
bash fan Emerald Sparx Gems: 3569
#4 Posted: 05:27:15 20/01/2014
That's also happened to me in one of my saved games where the white marker of a previous quest is still on the map.
All we had to do, was follow the damn train, CJ!
Bifrost Diamond Sparx Gems: 8053
#5 Posted: 20:23:34 21/01/2014
That always happens if you're unlucky,actually. I have an illegal copy of the game and thought that glitch was from it,but apparently not. Unfortunately, it seems that from Fire Minion to the penultimate boss you shouldn't stop progressing at all,and only backtrack after you're done;otherwise the only way to fix it is restarting the whole game.
It happened differently for me,though. I defeated the Fire Minion,went to Forgotten Worlds and saved the first village,but since I leveled up I decided to teleport back to Avalar then Dragon Realms to upgrade a few things. When I tried to return,the Professor isn't around to give you a lift in the Fire Minion's lair,and unless you're lucky the teleport spots in Forgotten Shore don't seem to be recognized even if you teleport from the Wizard's Peak or the Fire Minion's lair. So,as I said,don't backtrack until you defeat the boss in the Professor's village(he's easy anyway) and make sure you have at least 2 teleport spots found in that world,you want to guarantee you can go back to Forgotten Worlds by yourself.
I do art!
Pardon the intrusion!
Jaggedstar Platinum Sparx Gems: 6127
#6 Posted: 23:14:59 21/01/2014
That's happened to me in other games. Give yours a reboot. Sorry, that must be so frustrating!
Quote: Paytawn
oh my god
Eevee88 Emerald Sparx Gems: 3677
#7 Posted: 00:03:28 27/03/2014
Do this,


useless advise if i say so myself
Heading out, my liege? A commission, I presume? Then I shall accompany you. Just...ah, allow me to indulge in one more chapter...
Page 1 of 1

Please login or register a forum account to post a message.

Username Password Remember Me